• Brad King's avatar
    Drop compatibility with CMake < 2.4 · 7d47c693
    Brad King authored
    Drop all behavior activated by setting CMAKE_BACKWARDS_COMPATIBILITY to
    a value lower than 2.4, and generate an error when projects or the user
    attempt to do so.  In the error suggest using a CMake 2.8.x release.
    
    Teach cmake_minimum_required to warn about projects that do not require
    at least CMake 2.4.  They are not supported by CMake >= 3.0.
    
    Replace the documentation of CMAKE_BACKWARDS_COMPATIBILITY with a
    reference to policy CMP0001.
    7d47c693
Name
Last commit
Last update
..
Cache Loading commit data...
Executable Loading commit data...
Library Loading commit data...
CMakeLists.txt Loading commit data...
VarTests.cmake Loading commit data...
cmTestConfigure.h.in Loading commit data...
cmTestConfigureEscape.h.in Loading commit data...
cmTestGeneratedHeader.h.in Loading commit data...