• Brad King's avatar
    cmake_minimum_required: Optionally set policies with version range · 45408b5e
    Brad King authored
    Teach `cmake_minimum_required` and `cmake_policy(VERSION)` to support a
    version range of the form `<min>[...<max>]`.  Define this to mean that
    version `<min>` is required, but known policies up to those introduced
    by `<max>` will be set to `NEW`.  This will allow projects to easily
    specify a range of versions for which they have been updated.
    45408b5e
CMAKE_MINIMUM_REQUIRED_VERSION.rst 183 Bytes