Commit 9292e1b9 authored by Ben Boeckel's avatar Ben Boeckel

cmake: fix cmake_minimum_required

Set it only at the top-level and remove checks for policies which are
set to `NEW` and guaranteed to be so by the minimum version.
parent 4fb8185c
project(Xdmf)
cmake_minimum_required(VERSION 2.8.5)
#Needed to build DSM because relative paths are used to add its libraries
if (POLICY CMP0015)
cmake_policy(SET CMP0015 NEW)
endif ()
project(Xdmf)
if(WIN32)
......
project(XdmfCore)
cmake_minimum_required(VERSION 2.6)
if (POLICY CMP0015)
cmake_policy(SET CMP0015 NEW)
endif ()
include(CheckCXXSourceCompiles)
include(SetUpVersion)
......
project(XdmfDSM)
cmake_minimum_required(VERSION 2.6)
if (POLICY CMP0015)
cmake_policy(SET CMP0015 NEW)
endif ()
set(XdmfDSMLinkLibraries XdmfCore)
set(XdmfDSMLinkLibraryDir )
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment