Commit 59bf926f authored by Brad King's avatar Brad King

ENH: Added CMake version number restriction.

parent dbb84188
......@@ -49,6 +49,8 @@
#-----------------------------------------------------------------------------
# Instructions to use this script:
#
# CMake version 2.0.x is required, but 2.0.5 or better is preferred.
#
# Set the current working directory to the top of a source tree and
# run this script with this command:
#
......@@ -59,6 +61,10 @@
# signature. Note that Set/Get macros are capable of producing
# methods that might be mangled. These are also listed.
IF("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" LESS 2.0)
MESSAGE(FATAL_ERROR "CMake 2.0 or higher is required for this script.")
ENDIF("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" LESS 2.0)
# List of symbols that might be mangled.
SET(SYMBOLS
AbnormalTermination
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment