Commit ce3ed2b9 authored by David Thompson's avatar David Thompson
Browse files

Install Xcursor when building to make VTK happy.

parent f91db6db
......@@ -4,7 +4,8 @@
yum install -y \
zlib-devel libcurl-devel python-devel \
freeglut-devel glew-devel graphviz-devel libpng-devel \
libxcb libxcb-devel libXt-devel xcb-util xcb-util-devel mesa-libGL-devel mesa-libEGL-devel \
libxcb libxcb-devel libXt-devel xcb-util xcb-util-devel \
libXcursor-devel mesa-libGL-devel mesa-libEGL-devel \
libxkbcommon-devel file mesa-dri-drivers autoconf automake libtool chrpath
# Install EPEL
......
FROM fedora:31
MAINTAINER Utkarsh Ayachit <utkarsh.ayachit@kitware.com>
RUN dnf install -y /usr/bin/glxinfo git mesa-dri-drivers mesa-libGL* libxcrypt-compat.x86_64 && dnf clean all
RUN dnf install -y \
/usr/bin/glxinfo git mesa-dri-drivers mesa-libGL* \
libXcursor-devel libxcrypt-compat.x86_64 \
&& dnf clean all
......@@ -9,7 +9,7 @@
# newer compilers.
.centos7:
image: "kitware/paraview:ci-superbuild-centos7-20200210"
image: "kitware/paraview:ci-superbuild-centos7-20201027"
variables:
GIT_SUBMODULE_STRATEGY: none
......@@ -41,7 +41,7 @@
CMAKE_CONFIGURATION: linux_osmesa_static
.fedora31:
image: "kitware/paraview:ci-superbuild-fedora31-20200218"
image: "kitware/paraview:ci-superbuild-fedora31-20201027"
variables:
GIT_SUBMODULE_STRATEGY: none
......
......@@ -80,6 +80,7 @@ RUN apt-get update && apt-get install -y --no-install-recommends \
gfortran \
git \
libtool \
libxcursor-dev \
openssl \
pkg-config && \
if [ "${PYTHON_VERSION}" = "2" ]; then apt-get install -y --no-install-recommends python2.7-dev python-pip python-setuptools; fi && \
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment