Commit 2c7904d2 authored by Aron Helser's avatar Aron Helser
Browse files

Enable QT SVG support for paraview icons.

Force SVG support on.
parent d58c5d14
...@@ -358,6 +358,9 @@ set(_superbuild_default_nlohmannjson ON) ...@@ -358,6 +358,9 @@ set(_superbuild_default_nlohmannjson ON)
# set the default for qt5 to be 5.9 # set the default for qt5 to be 5.9
set(_superbuild_qt5_default_selection "5.9") set(_superbuild_qt5_default_selection "5.9")
# Force qt SVG support, so ParaView can use SVG icons
set(qt5_ENABLE_SVG ON CACHE INTERNAL "ParaView requires SVG support")
# ParaView's superbuild does not support static-everywhere builds. But let # ParaView's superbuild does not support static-everywhere builds. But let
# people around the check if they want it. # people around the check if they want it.
if (NOT PARAVIEW_I_WANT_EVERYTHING_STATIC) if (NOT PARAVIEW_I_WANT_EVERYTHING_STATIC)
......
...@@ -220,7 +220,10 @@ if (qt5_enabled) ...@@ -220,7 +220,10 @@ if (qt5_enabled)
set(qt5_plugin_prefix "lib") set(qt5_plugin_prefix "lib")
endif () endif ()
# Add SVG support, so ParaView can use SVG icons
set(qt5_plugins set(qt5_plugins
iconengines/${qt5_plugin_prefix}qsvgicon
imageformats/${qt5_plugin_prefix}qsvg
sqldrivers/${qt5_plugin_prefix}qsqlite) sqldrivers/${qt5_plugin_prefix}qsqlite)
if (WIN32) if (WIN32)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment