Commit 42ceea19 authored by Brad King's avatar Brad King

cargo: prep for 0.903.0

parent 4ac03f3f
Pipeline #66517 passed with stage
in 0 seconds
[package]
name = "gitlab"
version = "0.902.2"
version = "0.903.0"
authors = ["Ben Boeckel <ben.boeckel@kitware.com>"]
license = "MIT/Apache-2.0"
description = """
Gitlab API client.
"""
repository = "https://gitlab.kitware.com/utils/rust-gitlab"
documentation = "https://docs.rs/gitlab/0.902.2"
documentation = "https://docs.rs/gitlab/0.903.0"
readme = "README.md"
keywords = ["gitlab", "api"]
categories = ["web-programming", "api-bindings"]
......
......@@ -3,7 +3,7 @@
This library implements an interface to communicate with a Gitlab instance. Not
all API endpoints are implemented, but patches are welcome.
The API is based off of the GitLab 9.2 API v4 and will likely aggressively track
The API is based off of the GitLab 9.3 API v4 and will likely aggressively track
new API additions, so the newest release may not support talking to older
releases where fields have been added.
......@@ -33,13 +33,14 @@ possible. Instead, the crate uses the following versioning scheme:
* Gitlab 9.0 support → 0.900.x
* Gitlab 9.1 support → 0.901.x
* Gitlab 9.2 support → 0.902.x
* Gitlab 9.3 support → 0.903.x
Minor versions may fix bugs, add API endpoint bindings, or improve webhook
coverage. It is recommended to depend on the full version of the crate since
types may change in patch-level updates in order to match Gitlab's interface:
```toml
gitlab = "0.902.2"
gitlab = "0.903.0"
```
# API bugs
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment