Commit a8a1b1e8 authored by pugmire's avatar pugmire
Browse files

Add mpi support to turnip, change hawk to quadrics-mpi.


git-svn-id: http://visit.ilight.com/svn/visit/trunk/src@3382 18c085ea-50e0-402c-830e-de6fd14e8384
parent 9da3f919
......@@ -50,14 +50,14 @@ CXXFLAGS="-fPIC -Wno-deprecated $CXXFLAGS"
##
# This is for the vendor Quadrics MPI, but it has problems....
#LDFLAGS="-L/usr/lib/mpi/mpi_gcc334/lib $LDFLAGS"
#CPPFLAGS="-I/usr/lib/mpi/mpi_gcc334/include $CPPFLAGS"
#MPI_LIBS="-lmpi"
LDFLAGS="-L/usr/lib/mpi/mpi_gcc334/lib $LDFLAGS"
CPPFLAGS="-I/usr/lib/mpi/mpi_gcc334/include $CPPFLAGS"
MPI_LIBS="-lmpi"
# ... so instead, we're using MPICH.
LDFLAGS="-L/na/home/ahern/work/mpich-1.2.7p1/lib $LDFLAGS"
CPPFLAGS="-I/na/home/ahern/work/mpich-1.2.7p1/include $CPPFLAGS"
MPI_LIBS="-lmpich"
#LDFLAGS="-L/na/home/ahern/work/mpich-1.2.7p1/lib $LDFLAGS"
#CPPFLAGS="-I/na/home/ahern/work/mpich-1.2.7p1/include $CPPFLAGS"
#MPI_LIBS="-lmpich"
##
## If enable_viewer_mesa_stub in not set, then disable it.
......
......@@ -43,7 +43,11 @@ DEFAULT_SILO_LIBRARY=$VISITHOME/silo/4.5.1/linux_gcc-3.4.6/lib
CC="gcc"
CXX="g++"
CFLAGS=" -g -m64 -fPIC"
CXXFLAGS=" -g -m64 -fPIC"
CXXFLAGS=" -g -m64 -Wno-deprecated -fPIC -DMPICH_SKIP_MPICXX $CXXFLAGS"
CPPFLAGS=" -g -m64 -Wno-deprecated -fPIC -DMPICH_SKIP_MPICXX $CPPFLAGS"
## MPI
MPI_LIBS="-L/usr/local/lib -lmpich"
##
## Database reader plugin support libraries
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment