Commit 9dc063cf authored by js9's avatar js9
Browse files

allowing plugins to be compatible across point releases. (merging from RC)



git-svn-id: http://visit.ilight.com/svn/visit/trunk/src@2649 18c085ea-50e0-402c-830e-de6fd14e8384
parent cb6ba4d6
......@@ -43,6 +43,7 @@
#include <DebugStream.h>
#include <InvalidDirectoryException.h>
#include <InvalidPluginException.h>
#include <Utility.h>
#include <visit-config.h>
#include <visitstream.h>
#include <stdlib.h>
......@@ -588,6 +589,9 @@ PluginManager::GetPluginList(vector<pair<string,string> > &libs)
// Hank Childs, Thu Aug 30 08:45:02 PDT 2007
// Clean up debug statements.
//
// Jeremy Meredith, Wed Dec 12 16:09:38 EST 2007
// Allow plugins to be compatible across point releases.
//
// ****************************************************************************
void
......@@ -663,7 +667,7 @@ PluginManager::ReadPluginInfo()
pluginsWithNoVersion.push_back(pluginFile);
success = false;
}
else if (strcmp(*VisItPluginVersion, VERSION) != 0)
else if (!VisItVersionsCompatible(*VisItPluginVersion, VERSION))
{
pluginsWithWrongVersion.push_back(pluginFile);
success = false;
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment