Commit e8828361 authored by jcfr's avatar jcfr

COMP: Ensure vtkSlicerVersionConfigure is available for MRML libraries

This commit fixes the following windows build error by ensuring the
Slicer version header is generated.

fatal error C1083: Cannot open include file: 'vtkSlicerVersionConfigure.h':
 No such file or directory [D:\D\P\Slicer-0-build\Slicer-build\Modules\Loadable\Markups\MRML\vtkSlicerMarkupsModuleMRML.vcxproj]

git-svn-id: http://svn.slicer.org/Slicer4/trunk@27484 3bd1e089-480b-0410-8dfb-8563597acbee
parent 245d15a1
......@@ -1085,6 +1085,7 @@ endforeach()
# Add target configuring 'vtkSlicerVersionConfigure.h' at build time.
include(SlicerConfigureVersionHeaderTarget)
add_dependencies(SlicerBaseLogic SlicerConfigureVersionHeader)
add_dependencies(MRMLCore SlicerConfigureVersionHeader)
list(APPEND files ${CMAKE_CURRENT_BINARY_DIR}/vtkSlicerVersionConfigure.h)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment