Commit 974f0bb4 authored by jcfr's avatar jcfr

COMP: Qt5: Fix buildsystem regression ensuring QT_LIBRARIES is set (part 2)

Checking if the Qt5::<lib> target is valid is not possible because
find_package calls has not been done yet.

git-svn-id: http://svn.slicer.org/Slicer4/trunk@26952 3bd1e089-480b-0410-8dfb-8563597acbee
parent 5b5f75bc
......@@ -603,7 +603,7 @@ list(APPEND Slicer_REQUIRED_QT_MODULES ${Slicer_ADDITIONAL_REQUIRED_QT_MODULES})
if(Slicer_REQUIRED_QT_VERSION VERSION_GREATER "4.9")
set(QT_LIBRARIES)
foreach(lib IN LISTS Slicer_REQUIRED_QT_MODULES)
if(NOT TARGET Qt5::${lib})
if(lib MATCHES "^(LinguistTools)$")
continue()
endif()
list(APPEND QT_LIBRARIES Qt5::${lib})
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment