Commit 3be2c3f8 authored by jcfr's avatar jcfr

COMP: Update CMake minimum required version from 3.5 to 3.13.4 in internal projects

This commit is a follow-up of commit r27888 (COMP: Update CMake minimum
required version from 3.5 to 3.13)

From: Pablo Hernandez-Cerdan <pablo.hernandez.cerdan@outlook.com>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@27993 3bd1e089-480b-0410-8dfb-8563597acbee
parent a690b45c
......@@ -109,7 +109,7 @@
#
#
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
# TODO Support lookup of "Microsoft Visual C++ Compiler for Python 2.7 (x86, amd64)"
......
......@@ -18,7 +18,7 @@
#
################################################################################
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
function(list_to_string separator input_list output_string_var)
set(_string "")
......
......@@ -52,7 +52,7 @@
# ConfigurePrerequisites | Slicer_USE_CONFIGUREPREREQUISITES
# --------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
foreach(component NoExtensionSupport ConfigurePrerequisites)
string(TOUPPER ${component} _COMPONENT)
......
cmake_minimum_required(VERSION 3.9)
cmake_minimum_required(VERSION 3.13.4)
# Two possible approaches to use this script:
# (1) Copy and adapt to your specific configuration or (2) Use as it is by passing options
# Either way, the script can be executed using ctest:
......
......@@ -230,7 +230,7 @@ if(APPLE)
# for SuperBuild extensions.
file(WRITE ${slicer_extension_cpack_bundle_fixup_directory}/CMakeLists.txt
"cmake_minimum_required(VERSION 3.5)
"cmake_minimum_required(VERSION 3.13.4)
install(SCRIPT \"${slicer_extension_cpack_bundle_fixup_directory}/SlicerExtensionCPackBundleFixup.cmake\")")
set(source_dir "${slicer_extension_cpack_bundle_fixup_directory}")
set(build_dir "${slicer_extension_cpack_bundle_fixup_directory}-binary")
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
# Given a variable name, this function will display messages indicating what the current
# value of the variable.
......
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
if(Slicer_SOURCE_DIR)
......
......@@ -193,7 +193,7 @@ foreach(EXTENSION_NAME ${EXTENSION_LIST})
message(STATUS \"Generating '${EXTENSION_SOURCE_DIR}/CMakeLists.txt'\")
file(MAKE_DIRECTORY \"${EXTENSION_SOURCE_DIR}\")
file(WRITE \"${EXTENSION_SOURCE_DIR}/CMakeLists.txt\"
\"cmake_minimum_required(VERSION 3.5)
\"cmake_minimum_required(VERSION 3.13.4)
project(${proj} NONE)
message(FATAL_ERROR \\\"Failed to download extension using ${ext_ep_options_repository}\\n\${sanitized_error}\\\")
\"
......
cmake_minimum_required(VERSION 3.9)
cmake_minimum_required(VERSION 3.13.4)
# Two possible approaches to use this script:
# (1) Copy and adapt to your specific configuration or (2) Use as it is by passing options
# Either way, the script can be executed using ctest:
......
......@@ -3,7 +3,7 @@
# Check that TestExtC generated description file is valid.
#
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
# Sanity checks
set(expected_existing_vars
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
project(CLIExtensionTemplate)
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
project(EditorExtensionTemplate)
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
project(LoadableExtensionTemplate)
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
project(ScriptedLoadableExtensionTemplate)
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
project(ScriptedSegmentEditorEffectExtensionTemplate)
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
project(SuperBuildExtensionTemplate)
......
project(FreeSurfer)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
if(POLICY CMP0074)
......
project(ITKFactoryRegistration)
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
# --------------------------------------------------------------------------
# Dependencies
......
project(MRMLCLI)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
# --------------------------------------------------------------------------
......
project(MRMLCore)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
# --------------------------------------------------------------------------
......
project(MRMLDisplayableManager)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
# --------------------------------------------------------------------------
......
project(MRMLIDImageIO)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
......
project(MRMLLogic)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
# --------------------------------------------------------------------------
......
......@@ -2,7 +2,7 @@ project(qMRMLWidgets)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
# --------------------------------------------------------------------------
......
project(RemoteIO)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
# --------------------------------------------------------------------------
......
project(vtkAddon)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
# --------------------------------------------------------------------------
......
project(vtkITK)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
# --------------------------------------------------------------------------
......
project(vtkSegmentationCore)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
# --------------------------------------------------------------------------
......
project(vtkTeem)
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
#-----------------------------------------------------------------------------
# --------------------------------------------------------------------------
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
foreach(varname IN ITEMS
CTKAppLauncher_DIR
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
foreach(varname IN ITEMS
CMAKE_EXECUTABLE_SUFFIX
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
project(TemplateKey)
......
cmake_minimum_required(VERSION 3.5)
cmake_minimum_required(VERSION 3.13.4)
project(TemplateKey)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment