Commit c8fc138d authored by partyd's avatar partyd
Browse files

ENH: Officialy require CMake 2.8.2 as many of the sub modules already do.

git-svn-id: http://svn.slicer.org/Slicer4/trunk@15829 3bd1e089-480b-0410-8dfb-8563597acbee
parent 8710e283
project(BRAINSCommonLibProject)
set(LOCAL_PROJECT_NAME BRAINSCommonLib)
cmake_minimum_required(VERSION 2.8)
cmake_policy(VERSION 2.8)
cmake_minimum_required(VERSION 2.8.2)
cmake_policy(VERSION 2.8.2)
enable_testing()
include(Dart)
......
project(BRAINSDemonWarp)
set(LOCAL_PROJECT_NAME BRAINSDemonWarp)
cmake_minimum_required(VERSION 2.8)
cmake_policy(VERSION 2.8)
cmake_minimum_required(VERSION 2.8.2)
cmake_policy(VERSION 2.8.2)
enable_testing()
include(Dart)
......
project(BRAINSFit)
set(LOCAL_PROJECT_NAME BRAINSFit)
cmake_minimum_required(VERSION 2.8)
cmake_policy(VERSION 2.8)
cmake_minimum_required(VERSION 2.8.2)
cmake_policy(VERSION 2.8.2)
enable_testing()
include(Dart)
......
project(BRAINSFitIGT)
set(LOCAL_PROJECT_NAME BRAINSFitIGT)
cmake_minimum_required(VERSION 2.8)
cmake_policy(VERSION 2.8)
cmake_minimum_required(VERSION 2.8.2)
cmake_policy(VERSION 2.8.2)
enable_testing()
include(Dart)
......
project(BRAINSROIAuto)
set(LOCAL_PROJECT_NAME BRAINSROIAuto)
cmake_minimum_required(VERSION 2.8)
cmake_policy(VERSION 2.8)
cmake_minimum_required(VERSION 2.8.2)
cmake_policy(VERSION 2.8.2)
enable_testing()
include(Dart)
......
project(BRAINSResample)
set(LOCAL_PROJECT_NAME BRAINSResample)
cmake_minimum_required(VERSION 2.8)
cmake_policy(VERSION 2.8)
cmake_minimum_required(VERSION 2.8.2)
cmake_policy(VERSION 2.8.2)
enable_testing()
include(Dart)
......
project(BRAINSTools)
set(LOCAL_PROJECT_NAME BRAINSTools)
cmake_minimum_required(VERSION 2.8)
cmake_policy(VERSION 2.8)
cmake_minimum_required(VERSION 2.8.2)
cmake_policy(VERSION 2.8.2)
## Need to use local version that does not try to delete a local directory.
set(BRAINS_CMAKE_HELPER_DIR ${CMAKE_CURRENT_SOURCE_DIR}/BuildScripts)
......
PROJECT( DiffusionFiltering )
cmake_minimum_required(VERSION 2.8)
cmake_minimum_required(VERSION 2.8.2)
INCLUDE_DIRECTORIES(${DiffusionFiltering_SOURCE_DIR}/DiffusionApplicationsCommon)
......
#-----------------------------------------------------------------------------
cmake_minimum_required(VERSION 2.8)
cmake_minimum_required(VERSION 2.8.2)
#-----------------------------------------------------------------------------
PROJECT(Slicer)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment