Commit 26aad966 authored by jcfr's avatar jcfr
Browse files

COMP: Superbuild - Added a PLATFORM_CHECK flag

By default, it's set to TRUE

As of today, the check only ensure that MAC OSX >= 10.4 is used

git-svn-id: http://svn.slicer.org/Slicer4/trunk@13590 3bd1e089-480b-0410-8dfb-8563597acbee
parent 5335fc08
......@@ -37,6 +37,24 @@ FOREACH(policy ${project_policies})
ENDFOREACH()
#-----------------------------------------------------------------------------
# Platform check
#-----------------------------------------------------------------------------
set(PLATFORM_CHECK true)
if(PLATFORM_CHECK)
# See CMake/Modules/Platform/Darwin.cmake)
# 6.x == Mac OSX 10.2 (Jaguar)
# 7.x == Mac OSX 10.3 (Panther)
# 8.x == Mac OSX 10.4 (Tiger)
# 9.x == Mac OSX 10.5 (Leopard)
# 10.x == Mac OSX 10.6 (Snow Leopard)
if (DARWIN_MAJOR_VERSION LESS "8")
message(FATAL_ERROR "Only Mac OSX >= 10.4 are supported !")
endif()
endif()
#-----------------------------------------------------------------------------
# Update CMake module path
#------------------------------------------------------------------------------
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment