Commit 238730ca authored by jcfr's avatar jcfr
Browse files

ENH: Use CMAKE_DEPENDENT_OPTION to conditionally add...

ENH: Use CMAKE_DEPENDENT_OPTION to conditionally add Slicer_USE_PYTHONQT_WITH_TCL and Slicer_USE_NUMPY

git-svn-id: http://svn.slicer.org/Slicer4/trunk@17065 3bd1e089-480b-0410-8dfb-8563597acbee
parent 685e7eab
...@@ -111,9 +111,12 @@ MARK_AS_ADVANCED(Slicer_BUILD_QTSCRIPTEDMODULES) ...@@ -111,9 +111,12 @@ MARK_AS_ADVANCED(Slicer_BUILD_QTSCRIPTEDMODULES)
OPTION(Slicer_BUILD_CLI "Build Slicer CLI Plugins" ON) OPTION(Slicer_BUILD_CLI "Build Slicer CLI Plugins" ON)
OPTION(Slicer_BUILD_EXTENSIONS "Build Slicer 'trusted' extensions" OFF) OPTION(Slicer_BUILD_EXTENSIONS "Build Slicer 'trusted' extensions" OFF)
OPTION(Slicer_USE_PYTHONQT "Integrate a python-QT interpreter into Slicer." ON) OPTION(Slicer_USE_PYTHONQT "Integrate a python-QT interpreter into Slicer." ON)
OPTION(Slicer_USE_PYTHONQT_WITH_TCL "Enable PythonQt Tcl adapter layer" ON) CMAKE_DEPENDENT_OPTION(
#MARK_AS_ADVANCED(Slicer_USE_PYTHONQT_WITH_TCL) Slicer_USE_PYTHONQT_WITH_TCL "Enable PythonQt Tcl adapter layer" ON
OPTION(Slicer_USE_NUMPY "Build Slicer with NumPy" ON) "Slicer_USE_PYTHONQT" OFF)
CMAKE_DEPENDENT_OPTION(
Slicer_USE_NUMPY "Build Slicer with NumPy" ON
"Slicer_USE_PYTHONQT" OFF)
#OPTION(Slicer_USE_WEAVE "Build Slicer with Weave" OFF) #OPTION(Slicer_USE_WEAVE "Build Slicer with Weave" OFF)
#MARK_AS_ADVANCED(Slicer_USE_WEAVE) #MARK_AS_ADVANCED(Slicer_USE_WEAVE)
# OPTION(Slicer_USE_BatchMake "Build Slicer with BatchMake support." ON) # OPTION(Slicer_USE_BatchMake "Build Slicer with BatchMake support." ON)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment