Commit 6fa66ba5 authored by Sankhesh Jhaveri's avatar Sankhesh Jhaveri

Use the new Qt5 plugin architecture

Q_EXPORT_PLUGIN2 deprecated. Replaced by Q_PLUGIN_METADATA
Find the Qt5 RCC executable to generate qrc_* files.

Change-Id: I407ac783071895e2f01d51d0ddd71635e54813f3
parent a59a868b
......@@ -166,5 +166,10 @@ PV_PLUGIN_EXPORT(@PLUGIN_NAME@, @PLUGIN_NAME@_Plugin)
//-----------------------------------------------------------------------------
#ifdef plugin_type_gui
// Required to mark this as a Qt plugin.
#if QT_VERSION >= 0x050000
Q_DECLARE_INTERFACE(@PLUGIN_NAME@_Plugin, "com.kitware/paraview/@PLUGIN_NAME@")
Q_PLUGIN_METADATA(IID "com.kitware/paraview/@PLUGIN_NAME@")
#else
Q_EXPORT_PLUGIN2(@PLUGIN_NAME@, @PLUGIN_NAME@_Plugin)
#endif
#endif
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment