Commit 59311925 authored by Cory Quammen's avatar Cory Quammen

nvidiaindex: install correct version of nvrtc-builtins64 DLL

nvrtc-builtins64_80.dll comes with 2.1 of nvidiaindex library, but
nvrtc-builtins64_90.dll comes with 2.2. Package the one that has been
installed into the install directory.
parent 54db8446
......@@ -214,6 +214,7 @@ function (superbuild_add_packaging)
list(APPEND superbuild_export_variables
mesa_USE_SWR
mesa_SWR_ARCH
nvidiaindex_SOURCE_SELECTION
PARAVIEW_DEFAULT_SYSTEM_GL
PARAVIEW_PACKAGE_SUFFIX
PARAVIEW_CATALYST_EDITION)
......
......@@ -58,8 +58,15 @@ install(
if (nvidiaindex_enabled)
set(nvidiaindex_libraries
libdice
libnvindex
nvrtc-builtins64_80)
libnvindex)
# Need different nvrtc-builtins library depending on whether we are building
# with IndeX 2.1 or 2.2.
if (nvidiaindex_SOURCE_SELECTION STREQUAL "2.1")
list(APPEND nvidiaindex_libraries nvrtc-builtins64_80)
elseif (nvidiaindex_SOURCE_SELECTION STREQUAL "2.2")
list(APPEND nvidiaindex_libraries nvrtc-builtins64_90)
endif()
foreach (nvidiaindex_library IN LISTS nvidiaindex_libraries)
superbuild_windows_install_plugin("${nvidiaindex_library}.dll"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment