Commit d097449c authored by Scott Wittenburg's avatar Scott Wittenburg

Fix OpenGL warnings generated due to CMake deprecations

parent c891034a
......@@ -22,6 +22,8 @@ if("$ENV{RENDERING}" STREQUAL "egl")
set(EGL_gldispatch_LIBRARY "/usr/lib/x86_64-linux-gnu/libGLdispatch.so" CACHE FILEPATH "")
set(EGL_opengl_LIBRARY "/usr/lib/x86_64-linux-gnu/libOpenGL.so" CACHE FILEPATH "")
set(PARAVIEW_EXTRA_CMAKE_ARGUMENTS "-DOpenGL_GL_PREFERENCE:STRING=GLVND" CACHE STRING "")
# If we're going to have support for EGL, index would be nice too
set(ENABLE_nvidiaindex OFF CACHE BOOL "")
else()
......
......@@ -7,6 +7,6 @@ superbuild_add_extra_cmake_args(
-DEGL_LIBRARY:FILEPATH=${EGL_LIBRARY}
-DEGL_gldispatch_LIBRARY:FILEPATH=${EGL_gldispatch_LIBRARY}
-DEGL_opengl_LIBRARY:FILEPATH=${EGL_opengl_LIBRARY}
-DVTK_USE_OFFSCREEN_EGL:BOOL=ON
-DVTK_OPENGL_HAS_EGL:BOOL=ON
-DVTK_USE_OFFSCREEN:BOOL=OFF
-DVTK_USE_X:BOOL=OFF)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment