• Brad King's avatar
    ENH: Install VTK package version file for find_package · 19852427
    Brad King authored
    We teach VTK to install a package version file 'VTKConfigVersion.cmake'
    next to the package config file 'VTKConfig.cmake'.  This allows code
    like
    
      find_package(VTK 5.5)
    
    in user projects to find only compatible VTK versions.  Enforcement of
    the version check will only work when the user project runs with the
    FindVTK.cmake module from CMake 2.8 or higher.  The package version file
    will simply be ignored by older CMake versions.
    19852427
vtkGenerateVTKConfig.cmake 16.5 KB