Commit acd15bf1 authored by Brad King's avatar Brad King 💬 Committed by Kitware Robot
Browse files

Merge topic 'FindRuby_document_deprecated_variables' into release-3.18

e7fe0b24

 FindRuby: Add documentation for deprecated variables
Acked-by: Kitware Robot's avatarKitware Robot <kwrobot@kitware.com>
Merge-request: !5120
parents eaf81817 e7fe0b24
......@@ -48,10 +48,21 @@ This module will set the following variables in your project:
Ruby patch version.
Also:
The following variables are also provided for compatibility reasons,
don't use them in new code:
``RUBY_EXECUTABLE``
same as Ruby_EXECUTABLE.
``RUBY_INCLUDE_DIRS``
same as Ruby_INCLUDE_DIRS.
``RUBY_INCLUDE_PATH``
same as Ruby_INCLUDE_DIRS, only provided for compatibility reasons, don't use it
same as Ruby_INCLUDE_DIRS.
``RUBY_LIBRARY``
same as Ruby_LIBRARY.
``RUBY_VERSION``
same as Ruby_VERSION.
``RUBY_FOUND``
same as Ruby_FOUND.
Hints
^^^^^
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment