Commit 185ce792 authored by Ben Boeckel's avatar Ben Boeckel
Browse files

pybind11: support Python versions newer than 3.7

parent 9f970d4d
Pipeline #219121 waiting for manual action with stages
diff -u -Nru5 pybind11-97784dad3e518ccb415d5db57ff9b933495d9024/tools/pybind11Tools.cmake pybind11-97784dad3e518ccb415d5db57ff9b933495d9024.new-python/tools/pybind11Tools.cmake
--- pybind11-97784dad3e518ccb415d5db57ff9b933495d9024/tools/pybind11Tools.cmake 2019-05-12 17:35:49.000000000 -0400
+++ pybind11-97784dad3e518ccb415d5db57ff9b933495d9024.new-python/tools/pybind11Tools.cmake 2021-03-16 16:06:54.655625207 -0400
@@ -10,11 +10,11 @@
# Add a CMake parameter for choosing a desired Python version
if(NOT PYBIND11_PYTHON_VERSION)
set(PYBIND11_PYTHON_VERSION "" CACHE STRING "Python version to use for compiling modules")
endif()
-set(Python_ADDITIONAL_VERSIONS 3.7 3.6 3.5 3.4)
+set(Python_ADDITIONAL_VERSIONS 3.10 3.9 3.8 3.7 3.6 3.5 3.4)
find_package(PythonLibsNew ${PYBIND11_PYTHON_VERSION} REQUIRED)
include(CheckCXXCompilerFlag)
include(CMakeParseArguments)
......@@ -9,3 +9,6 @@ superbuild_add_project(pybind11
DEPENDS_OPTIONAL python2 python3
CMAKE_ARGS
-DPYBIND11_TEST:BOOL=OFF)
superbuild_apply_patch(pybind11 new-python
"Add support for newer Python releases")
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment