Commit 11821201 authored by Ben Boeckel's avatar Ben Boeckel
Browse files

smtk: 21.05 and newer have a CMake package that can be found by default

parent decfa380
Pipeline #225483 waiting for manual action with stages
......@@ -107,13 +107,16 @@ superbuild_add_project(smtk
${SMTK_EXTRA_CMAKE_ARGUMENTS})
set(smtk_config_version ${smtk_version_major}.${smtk_version_minor}.${smtk_version_patch})
if (WIN32)
set(smtk_config_path "cmake/smtk/${smtk_config_version}")
else ()
set(smtk_config_path "lib/cmake/smtk/${smtk_config_version}")
if (smtk_SOURCE_SELECTION STREQUAL "master" OR
smtk_version VERSION_LESS "21.05")
set(smtk_config_version ${smtk_version_major}.${smtk_version_minor}.${smtk_version_patch})
if (WIN32)
set(smtk_config_path "cmake/smtk/${smtk_config_version}")
else ()
set(smtk_config_path "lib/cmake/smtk/${smtk_config_version}")
endif ()
superbuild_add_extra_cmake_args(-Dsmtk_DIR:PATH=<INSTALL_DIR>/${smtk_config_path})
endif ()
superbuild_add_extra_cmake_args(-Dsmtk_DIR:PATH=<INSTALL_DIR>/${smtk_config_path})
if ((CMAKE_CXX_COMPILER_ID STREQUAL "AppleClang" AND NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS "7.0") OR
(CMAKE_CXX_COMPILER_ID STREQUAL "Clang" AND NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS "3.5"))
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment