• Stephen Kelly's avatar
    QtAutomoc: Get the Qt version through the target link interface · fa55751f
    Stephen Kelly authored
    In Qt 5.1, Qt5::Core has a INTERFACE_QT_MAJOR_VERSION property
    of '5', and since CMake 2.8.11, Qt4::QtCore has an
    INTERFACE_QT_MAJOR_VERSION of '4'. This was introduced in
    commit 4aa10cd6 (FindQt4: Set the INTERFACE_QT_MAJOR_VERSION for
    Qt4::QtCore, 2013-03-16), to produce an error if Qt 4 and Qt 5
    are erroneously used by the same target. This can also be used
    however to determine the Qt major version, and therefore the
    particular moc executable to use during automoc steps. This means
    that targets in a single buildsystem can use a selection of Qt 4
    and Qt 5, and still take advantage of the CMAKE_AUTOMOC feature
    without conflicting.
    fa55751f
Name
Last commit
Last update
..
CMakeLists.txt Loading commit data...
main.cpp Loading commit data...
main_qt4.cpp Loading commit data...
main_qt5.cpp Loading commit data...