Set minimum version for LibUV to 1.0.0

Older versions of libuv did not have the uv_loop_close API.  It first
showed up in unstable releases ~ v0.11.20 but was not available in
a stable release until v1.0
1 job for check-libuv-minimum-version
Status Job ID Name Coverage
  External
passed kwrobot-commit-check