Commit 8bb3b3d3 authored by Patrick Gansterer's avatar Patrick Gansterer Committed by Brad King

VS: Use version-specific subsystem for WinCE compiler id (#14440)

The subsystem must be set to WINDWOSCE for some SDKs to link an
executable. Set it to 9 for VS2005 and to 8 for VS2008, since the
value differs between the different Visual Studio versions.
parent faef6b4e
......@@ -133,7 +133,11 @@ Id flags: ${testflags}
endif()
if(CMAKE_VS_WINCE_VERSION)
set(id_entrypoint "mainACRTStartup")
set(id_subsystem 9)
if("${vs_version}" VERSION_LESS 9)
set(id_subsystem 9)
else()
set(id_subsystem 8)
endif()
else()
set(id_subsystem 1)
endif()
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment