Commit 1c03c12b authored by Brad King's avatar Brad King

jsoncpp: Require version 1.4.1 when using system-provided library

We need the `failIfExtra` diagnostic added by that version.
parent 4a8898cd
...@@ -544,7 +544,7 @@ macro (CMAKE_BUILD_UTILITIES) ...@@ -544,7 +544,7 @@ macro (CMAKE_BUILD_UTILITIES)
#--------------------------------------------------------------------- #---------------------------------------------------------------------
# Build jsoncpp library. # Build jsoncpp library.
if(CMAKE_USE_SYSTEM_JSONCPP) if(CMAKE_USE_SYSTEM_JSONCPP)
find_package(JsonCpp) find_package(JsonCpp 1.4.1)
if(NOT JsonCpp_FOUND) if(NOT JsonCpp_FOUND)
message(FATAL_ERROR message(FATAL_ERROR
"CMAKE_USE_SYSTEM_JSONCPP is ON but a JsonCpp is not found!") "CMAKE_USE_SYSTEM_JSONCPP is ON but a JsonCpp is not found!")
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment