• Brad King's avatar
    FortranCInterface: Do not use cmake_policy(VERSION) · b3795df2
    Brad King authored
    Do not force a specific policy version in the module because it prevents
    projects from setting newer policies to NEW.  In particular, projects
    may want to set CMP0056 to NEW to affect any try_compile calls in this
    module.
    
    Use of this was added in commit v2.8.2~714 (FortranCInterface: Use CMake
    2.8.0 behavior, 2009-11-17) in order to set CMP0007 to NEW.  Simply set
    this policy explicitly instead.
    b3795df2
FortranCInterface.cmake 12.3 KB