Commit e73d1ad0 authored by Brad King's avatar Brad King Committed by Kitware Robot

Merge topic 'MakeDocsWorkWithDocutilsBefore0_11'

fb107d84 Help: Fix Sphinx extension with docutils < 0.11
parents c23332c3 fb107d84
......@@ -14,7 +14,12 @@ import re
from docutils.parsers.rst import Directive, directives
from docutils.transforms import Transform
from docutils.utils.error_reporting import SafeString, ErrorString
try:
from docutils.utils.error_reporting import SafeString, ErrorString
except ImportError:
# error_reporting was not in utils before version 0.11:
from docutils.error_reporting import SafeString, ErrorString
from docutils import io, nodes
from sphinx.directives import ObjectDescription
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment