Commit 56c1ea40 authored by Ben Boeckel's avatar Ben Boeckel Committed by Brad King

cmCTestGIT: fix git version references

Git does not use a 4-component version number.
parent 90f24f01
......@@ -274,14 +274,14 @@ bool cmCTestGIT::UpdateImpl()
const char* git = this->CommandLineTool.c_str();
const char* recursive = "--recursive";
// Git < 1.6.5.0 did not support --recursive
// Git < 1.6.5 did not support submodule --recursive
if(this->GetGitVersion() < cmCTestGITVersion(1,6,5,0))
{
recursive = 0;
// No need to require >= 1.6.5.0 if there are no submodules.
// No need to require >= 1.6.5 if there are no submodules.
if(cmSystemTools::FileExists((top_dir + "/.gitmodules").c_str()))
{
this->Log << "Git < 1.6.5.0 cannot update submodules recursively\n";
this->Log << "Git < 1.6.5 cannot update submodules recursively\n";
}
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment