cmCMakeMinimumRequired.cxx 3.32 KB
Newer Older
1
2
/*=========================================================================

3
  Program:   CMake - Cross-Platform Makefile Generator
4
5
6
7
8
  Module:    $RCSfile$
  Language:  C++
  Date:      $Date$
  Version:   $Revision$

9
10
  Copyright (c) 2002 Kitware, Inc., Insight Consortium.  All rights reserved.
  See Copyright.txt or http://www.cmake.org/HTML/Copyright.html for details.
11
12
13
14
15
16
17
18

     This software is distributed WITHOUT ANY WARRANTY; without even 
     the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR 
     PURPOSE.  See the above copyright notices for more information.

=========================================================================*/
#include "cmCMakeMinimumRequired.h"

19
20
#include "cmVersion.h"

21
22
23
// cmCMakeMinimumRequired
bool cmCMakeMinimumRequired::InitialPass(std::vector<std::string> const& args)
{
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
  // Process arguments.
  std::string version_string;
  bool doing_version = false;
  bool fatal_error = false;
  for(unsigned int i=0; i < args.size(); ++i)
    {
    if(args[i] == "VERSION")
      {
      doing_version = true;
      }
    else if(args[i] == "FATAL_ERROR")
      {
      if(doing_version)
        {
        this->SetError("called with no value for VERSION.");
        return false;
        }
      doing_version = false;
      fatal_error = true;
      }
    else if(doing_version)
      {
      doing_version = false;
      version_string = args[i];
      }
    else
      {
      cmOStringStream e;
      e << "called with unknown argument \"" << args[i].c_str() << "\".";
      this->SetError(e.str().c_str());
      return false;
      }
    }
  if(doing_version)
58
    {
59
    this->SetError("called with no value for VERSION.");
60
61
    return false;
    }
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83

  // Make sure there was a version to check.
  if(version_string.empty())
    {
    return true;
    }

  // Save the required version string.
  m_Makefile->AddDefinition("CMAKE_MINIMUM_REQUIRED_VERSION", version_string.c_str());

  // Get the current version number.
  int current_major = m_Makefile->GetMajorVersion();
  int current_minor = m_Makefile->GetMinorVersion();
  int current_patch = m_Makefile->GetPatchVersion();

  // Parse the required version number.  If no patch-level is given
  // use zero.
  int required_major = 0;
  int required_minor = 0;
  int required_patch = 0;
  if(sscanf(version_string.c_str(), "%d.%d.%d",
            &required_major, &required_minor, &required_patch) < 2)
84
    {
85
86
87
88
    cmOStringStream e;
    e << "could not parse VERSION \"" << version_string.c_str() << "\".";
    this->SetError(e.str().c_str());
    return false;
89
    }
90
91
92
93
94
95
96
97

  // Compare the version numbers.
  if(current_major < required_major ||
     current_major == required_major &&
     current_minor < required_minor ||
     current_major == required_major &&
     current_minor == required_minor &&
     current_patch < required_patch)
98
    {
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
    // The current version is too low.
    cmOStringStream e;
    if(!fatal_error)
      {
      e << "WARNING: ";
      }
    e << "This project requires version " << version_string.c_str() << " of CMake.  "
      << "You are running version "
      << current_major << "." << current_minor << "." << current_patch << ".\n";
    if(fatal_error)
      {
      cmSystemTools::Error(e.str().c_str());
      cmSystemTools::SetFatalErrorOccured();
      }
    else
      {
      cmSystemTools::Message(e.str().c_str());
      }
117
    }
118

119
120
121
  return true;
}