An update will be applied December 9th, between 12PM and 1:00PM EST (UTC -5:00). The site may be slow during that time.

Commit 143ca892 authored by Brad King's avatar Brad King
Browse files

cargo: prep for 0.1002.0

parent 6ac89218
[package] [package]
name = "gitlab" name = "gitlab"
version = "0.1001.0" version = "0.1002.0"
authors = ["Ben Boeckel <ben.boeckel@kitware.com>"] authors = ["Ben Boeckel <ben.boeckel@kitware.com>"]
license = "MIT/Apache-2.0" license = "MIT/Apache-2.0"
description = """ description = """
Gitlab API client. Gitlab API client.
""" """
repository = "https://gitlab.kitware.com/utils/rust-gitlab" repository = "https://gitlab.kitware.com/utils/rust-gitlab"
documentation = "https://docs.rs/gitlab/0.1001.0" documentation = "https://docs.rs/gitlab/0.1002.0"
readme = "README.md" readme = "README.md"
keywords = ["gitlab", "api"] keywords = ["gitlab", "api"]
categories = ["web-programming", "api-bindings"] categories = ["web-programming", "api-bindings"]
......
...@@ -3,7 +3,7 @@ ...@@ -3,7 +3,7 @@
This library implements an interface to communicate with a Gitlab instance. Not This library implements an interface to communicate with a Gitlab instance. Not
all API endpoints are implemented, but patches are welcome. all API endpoints are implemented, but patches are welcome.
The API is based off of the GitLab 10.1 API v4 and will likely aggressively track The API is based off of the GitLab 10.2 API v4 and will likely aggressively track
new API additions, so the newest release may not support talking to older new API additions, so the newest release may not support talking to older
releases where fields have been added. releases where fields have been added.
...@@ -38,13 +38,14 @@ possible. Instead, the crate uses the following versioning scheme: ...@@ -38,13 +38,14 @@ possible. Instead, the crate uses the following versioning scheme:
* Gitlab 9.5 support → 0.905.x * Gitlab 9.5 support → 0.905.x
* Gitlab 10.0 support → 0.1000.x * Gitlab 10.0 support → 0.1000.x
* Gitlab 10.1 support → 0.1001.x * Gitlab 10.1 support → 0.1001.x
* Gitlab 10.2 support → 0.1002.x
Minor versions may fix bugs, add API endpoint bindings, or improve webhook Minor versions may fix bugs, add API endpoint bindings, or improve webhook
coverage. It is recommended to depend on the full version of the crate since coverage. It is recommended to depend on the full version of the crate since
types may change in patch-level updates in order to match Gitlab's interface: types may change in patch-level updates in order to match Gitlab's interface:
```toml ```toml
gitlab = "0.1001.0" gitlab = "0.1002.0"
``` ```
# API bugs # API bugs
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment