Commit b1f4e620 authored by Brad King's avatar Brad King
Browse files

Help: Reference cmake_minimum_required from cmake_policy docs



Note in a few places of the cmake_policy() command documentation
that the cmake_minimum_required() command can set policies too.
Inspired-by: default avatarPeter Kümmel <syntheticpp@gmx.net>
parent 69a23cb2
......@@ -36,6 +36,9 @@ version and tells newer CMake versions to warn about their new policies.
The policy version specified must be at least 2.4 or the command will
report an error.
Note that the :command:`cmake_minimum_required(VERSION)`
command implicitly calls ``cmake_policy(VERSION)`` too.
Setting Policies Explicitly
'''''''''''''''''''''''''''
......@@ -79,6 +82,9 @@ entries on the policy stack::
Each ``PUSH`` must have a matching ``POP`` to erase any changes.
This is useful to make temporary changes to policy settings.
Calls to the :command:`cmake_minimum_required(VERSION)`,
``cmake_policy(VERSION)``, or ``cmake_policy(SET)`` commands
influence only the current top of the policy stack.
Commands created by the :command:`function` and :command:`macro`
commands record policy settings when they are created and
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment