1. 04 Aug, 2017 1 commit
  2. 03 Jul, 2017 1 commit
  3. 21 Jun, 2017 1 commit
  4. 30 May, 2017 1 commit
  5. 26 Apr, 2017 1 commit
  6. 05 Apr, 2017 1 commit
  7. 29 Mar, 2017 2 commits
  8. 23 Mar, 2017 1 commit
  9. 21 Mar, 2017 1 commit
  10. 17 Mar, 2017 1 commit
  11. 10 Mar, 2017 1 commit
  12. 04 Jan, 2017 1 commit
  13. 14 Dec, 2016 1 commit
  14. 27 Oct, 2016 1 commit
  15. 24 Oct, 2016 1 commit
  16. 20 Oct, 2016 8 commits
  17. 19 Oct, 2016 1 commit
  18. 23 Sep, 2016 1 commit
  19. 21 Sep, 2016 1 commit
  20. 16 Sep, 2016 3 commits
  21. 14 Sep, 2016 1 commit
  22. 13 Sep, 2016 2 commits
  23. 08 Sep, 2016 1 commit
  24. 26 Aug, 2016 1 commit
    • T.J. Corona's avatar
      Warn during compilation if data testing conditions are met. · ab6589c6
      T.J. Corona authored
      The requirement for building tests that use test data is the existence of
      the data directory AND the explicit use of hdf5. Originally, if the data
      directory were specified but hdf5 were not enabled, the tests that use
      data were silently dropped. This commit adds a compile-time warning when
      the abovementioned condition holds.
      ab6589c6
  25. 25 Aug, 2016 1 commit
    • T.J. Corona's avatar
      Remove auto-generation of SharedPtr.h · 7ba04a00
      T.J. Corona authored
      This commit is in reference to Issue #40. Originally, the header file
      SharedPtr.h was generated to accommodate pre-C++11 builds. Now that we
      enforce the use of C++11, the optional use of boost's shared pointers is
      unnecessary. This commit removes the mechanisms for choosing between stl's
      and boost's shared_ptr, and adds a static header file that uses the stl
      version.
      7ba04a00
  26. 23 Aug, 2016 1 commit
  27. 22 Jun, 2016 1 commit
    • Robert Maynard's avatar
      Move smtk minimum required version to CMake 3.5. · 6c8fccd0
      Robert Maynard authored
      We are moving the minimum require CMake version for two reasons. The first
      is that SMTK requires a C++11 compiler, and we need to use CMake features
      from CMake 3.1+. Secondly is that ParaView now requires CMake 3.5 now.
      6c8fccd0
  28. 03 Jun, 2016 1 commit
  29. 01 Jun, 2016 1 commit