Commit 2480ac32 authored by Ben Boeckel's avatar Ben Boeckel

gitlab-ci: declare that Linux 3.17 is needed

Fedora's Qt builds use syscalls added in Linux 3.17, so the CI host
needs at least that new of a kernel in order to run these jobs.
parent 98112c6c
......@@ -86,7 +86,7 @@ build:fedora33-shared-debug-mpi-python-qt:
extends:
- .fedora33_shared_debug_mpi_python_qt
- .cmake_build_linux
- .linux_builder_tags
- .linux_qt_builder_tags
- .cmake_build_artifacts
- .run_manually
......@@ -94,7 +94,7 @@ test:fedora33-shared-debug-mpi-python-qt:
extends:
- .fedora33_shared_debug_mpi_python_qt
- .cmake_test_linux
- .linux_tester_tags
- .linux_qt_tester_tags
- .cmake_test_artifacts
- .run_automatically
dependencies:
......
......@@ -104,6 +104,22 @@
- linux
- x11
.linux_qt_builder_tags:
tags:
- build
- docker
- linux
- linux-3.17 # needed to run Qt binaries from Fedora 33
- paraview
.linux_qt_tester_tags:
tags:
- docker
- paraview
- linux
- linux-3.17
- x11
## Linux-specific scripts
.before_script_linux: &before_script_linux
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment