Commit 376f414c authored by Ben Boeckel's avatar Ben Boeckel
Browse files

paraview: disable the nodeeditor by default

It requires graphviz which is not provided by the superbuild. Since a
relatively new version for some target platforms is required (Dec 2016),
just disable it by default until the `graphviz` project is available in
the superbuild itself.
parent 3e4223df
......@@ -336,6 +336,8 @@ The following flags affect ParaView directly:
* `PARAVIEW_ENABLE_VRPLUGIN` (default `ON`): Enables the VRPlugin. If
`vrpn` is enabled, the VRPlugin will support input devices through a VRPN
connection. VRUI support is enabled unconditionally on Linux.
* `PARAVIEW_ENABLE_NODEEDITOR` (default `OFF`): Enables the NodeEditor
plugin.
#### ParaView editions
......
......@@ -86,6 +86,9 @@ if (NOT PARAVIEW_BUILD_EDITION STREQUAL "CANONICAL")
set(PARAVIEW_ENABLE_MOTIONFX OFF)
endif ()
option(PARAVIEW_ENABLE_NODEEDITOR "Enable NodeEditor plugin" OFF)
mark_as_advanced(PARAVIEW_ENABLE_NODEEDITOR)
option(PARAVIEW_ENABLE_VRPLUGIN "Enable VRPlugin" ON)
mark_as_advanced(PARAVIEW_ENABLE_VRPLUGIN)
......@@ -219,6 +222,7 @@ superbuild_add_project(paraview
-DPARAVIEW_ENABLE_XDMF3:BOOL=${xdmf3_enabled}
-DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON
-DPARAVIEW_PLUGIN_ENABLE_GmshIO:BOOL=${gmsh_enabled}
-DPARAVIEW_PLUGIN_ENABLE_NodeEditor:BOOL=${PARAVIEW_ENABLE_NODEEDITOR}
-DPARAVIEW_PLUGIN_ENABLE_LookingGlass:BOOL=${lookingglass_enabled}
-DPARAVIEW_PLUGIN_ENABLE_OpenVR:BOOL=${openvr_enabled}
# No netcdftime module in the package.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment