Commit fce242b4 authored by Ben Boeckel's avatar Ben Boeckel

python3.4: update assumption

parent aa7ce395
......@@ -20,13 +20,13 @@ include(CMakeParseArguments)
# Find a Python executable to run the `fixup_bundle` scripts.
if (NOT superbuild_python_executable)
find_package(PythonInterp 2.7)
find_package(PythonInterp 3.4)
if (PYTHONINTERP_FOUND)
set(superbuild_python_executable
"${PYTHON_EXECUTABLE}")
else ()
message(FATAL_ERROR
"Could not find a Python executable newer than 2.7; one is required "
"Could not find a Python executable newer than 3.4; one is required "
"to create packages on Linux and Windows.")
endif ()
endif ()
......@@ -449,7 +449,7 @@ function (superbuild_unix_install_python)
foreach (python_module IN LISTS python_modules)
superbuild_unix_install_python_module(\"\${CMAKE_INSTALL_PREFIX}\"
\"\${python_module}\" \"\${module_directories}\" \"lib/python2.7${_install_python_MODULE_DESTINATION}\")
\"\${python_module}\" \"\${module_directories}\" \"lib/python3.4${_install_python_MODULE_DESTINATION}\")
endforeach ()"
COMPONENT superbuild)
endfunction ()
......
......@@ -313,7 +313,7 @@ macro (superbuild_add_project_python _name)
else ()
set(_superbuild_python_args
"--single-version-externally-managed"
"--install-lib=lib/python2.7/site-packages"
"--install-lib=lib/python3.4/site-packages"
"--prefix=")
endif ()
......
option(python_FIND_LIBRARIES "Require system Python development files" ON)
mark_as_advanced(python_FIND_LIBRARIES)
find_package(PythonInterp 2.7 REQUIRED)
find_package(PythonInterp 3.4 REQUIRED)
if (python_FIND_LIBRARIES)
find_package(PythonLibs 2.7 REQUIRED)
find_package(PythonLibs 3.4 REQUIRED)
if (NOT PYTHON_VERSION_STRING VERSION_EQUAL PYTHONLIBS_VERSION_STRING AND
NOT PYTHON_I_KNOW_WHAT_IM_DOING)
message(FATAL_ERROR
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment