Commit cdca6c3c authored by Andrew Bauer's avatar Andrew Bauer
Browse files

Setting proper OpenVDB library version

There seems to be incompatibility with the OpenVDB v9 libraries.
For now at least set the OpenVDB library to version 8 in CMake
configuration to avoid issues.
parent 0c8a311e
......@@ -6,7 +6,13 @@ mark_as_advanced(OpenVDB_CMAKE_PATH)
list(INSERT CMAKE_MODULE_PATH 0
"${OpenVDB_CMAKE_PATH}")
vtk_module_find_package(PACKAGE OpenVDB)
vtk_module_find_package(PACKAGE OpenVDB VERSION 8)
STRING(REGEX MATCH "[0-9]*" OpenVDB_MAJOR_VERSION ${OpenVDB_VERSION})
if (NOT ${OpenVDB_MAJOR_VERSION} STREQUAL "8")
message(ERROR " OpenVDB needs to be major version 8 but is version ${OpenVDB_VERSION}")
endif()
set(classes
vtkOpenVDBWriter)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment