Commit 345b5212 authored by Bastien Jacquet's avatar Bastien Jacquet
Browse files

Disable manually setting the sdk for Qt on OSX

On OSX lesser than 10.10, with newer Xcode, setting the 10.11 sdk
makes corewlan failing to build within bearer plugin (fails to link to opennssl).
Not setting it manually resolves the issue.
For similar issue see:
dcthomp/cmb-superbuild@31dd44d6
parent f2aa9b35
......@@ -16,8 +16,9 @@ elseif (APPLE)
message(FATAL "CMAKE_OSX_SYSROOT or CMAKE_OSX_ARCHITECTURES are not configured")
endif()
list (APPEND qt_options
-sdk ${CMAKE_OSX_SYSROOT}
#-sdk ${CMAKE_OSX_SYSROOT} #corewlan is failing on 10.9 with 10.11 sdk
-arch ${CMAKE_OSX_ARCHITECTURES}
-platform unsupported/macx-clang-libc++
-qt-libpng
-system-zlib
)
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment