[ci][doc] Upgrade to Qt5.10.1 on windows

The windows ci was relying on Qt 5.10.0. This version has a bug that caused
a debug message to be display in some consol.
Also linux and osx are using Qt 5.10.1, so now all os use the same version.

See Qt's bug report for more information: https://bugreports.qt.io/browse/QTBUG-65532
1 job for !188 with CI/Windows/UpgradeQt
latest merge request