• Brad King's avatar
    cmake: declare support for CMake versions through 3.12 · c36289f1
    Brad King authored
    CMake 3.12 introduces a `...<max>` syntax in the version given to
    `cmake_minimum_required` to automatically set policies to NEW up
    to that version.  Use it to avoid listing policies explicitly.
    
    The syntax is compatible with older versions of CMake such that they use
    the extended version string for the `CMAKE_MINIMUM_REQUIRED_VERSION`
    variable (which we don't use) but otherwise ignore it.
    c36289f1
CMakeLists.txt 2.38 KB