Updates will be applied - 3:30pm EDT (UTC -400). No downtime expected.

Commit ebac805b authored by David Gobbi's avatar David Gobbi

Consolidate the qt4 and qt5 python interactor widgets.

parent 1cea85a8
......@@ -155,6 +155,7 @@ if(PYTHON_EXECUTABLE)
${CMAKE_CURRENT_BINARY_DIR}/vtk/gtk
${CMAKE_CURRENT_BINARY_DIR}/vtk/qt4
${CMAKE_CURRENT_BINARY_DIR}/vtk/qt5
${CMAKE_CURRENT_BINARY_DIR}/vtk/qt
${CMAKE_CURRENT_BINARY_DIR}/vtk/tk
${CMAKE_CURRENT_BINARY_DIR}/vtk/util
${CMAKE_CURRENT_BINARY_DIR}/vtk/wx
......@@ -216,6 +217,8 @@ if(PYTHON_EXECUTABLE)
# PyQt related files
list(APPEND VTK_PYTHON_FILES
vtk/qt/__init__
vtk/qt/QVTKRenderWindowInteractor
vtk/qt4/__init__
vtk/qt4/QVTKRenderWindowInteractor
vtk/qt5/__init__
......
This diff is collapsed.
"""Qt module for VTK/Python.
Example usage:
import sys
import PyQt5
from PyQt5.QtWidgets import QApplication
from vtk.qt.QVTKRenderWindowInteractor import QVTKRenderWindowInteractor
app = QApplication(sys.argv)
widget = QVTKRenderWindowInteractor()
widget.Initialize()
widget.Start()
renwin = widget.GetRenderWindow()
For more information, see QVTKRenderWidgetConeExample() in the file
QVTKRenderWindowInteractor.py.
"""
import sys
# PyQtImpl can be set by the user
PyQtImpl = None
# Has an implementation has been imported yet?
for impl in ["PyQt5", "PyQt4", "PySide"]:
if impl in sys.modules:
PyQtImpl = impl
break
__all__ = ['QVTKRenderWindowInteractor']
"""PyQt v4 widget for VTK."""
"""PyQt v4 widget for VTK.
This module is a version of the vtk.qt module that requires Qt4.
If you do not specifically require Qt4, then use vtk.qt instead.
"""
__all__ = ['QVTKRenderWindowInteractor']
"""PyQt v5 widget for VTK."""
"""PyQt v5 widget for VTK.
This module is a version of the vtk.qt module that requires Qt5.
If you do not specifically require Qt5, then use vtk.qt instead.
"""
__all__ = ['QVTKRenderWindowInteractor']
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment